What’s Vulnerable › Vulnerabilities
CVE-2022-3539: Testimonials (Free < 2.7, Pro < 1.0.8) - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Testimonials WordPress plugin before 2.7, super-testimonial-pro WordPress plugin before 1.0.8 do not sanitize and escape its settings, allowing high privilege users such as admin to perform cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- themepoints Super Testimonial – Testimonial & Customer Review Slider Plugin for WordPress: before 1.0.8; before 2.7 — fixed in 1.0.8, 2.7
How to fix
Upgrade to a fixed version: themepoints Super Testimonial – Testimonial & Customer Review Slider Plugin for WordPress 1.0.8, 2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ab3b0052-1a74-4ba3-b6d2-78cfe56029db
- https://wpscan.com/vulnerability/ab3b0052-1a74-4ba3-b6d2-78cfe56029db
Get alerted when CVE-2022-3539 or the next vulnerability affects your stack