What’s Vulnerable › Vulnerabilities
CVE-2022-35415
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-16 · updated 2026-06-17
- Weakness: CWE-20
Description
An improper input validation in NI System Configuration Manager before 22.5 may allow a privileged user to potentially enable escalation of privilege via local access.
Affected products
- NI Configuration Manager: before 22.5.0 — fixed in 22.5.0
How to fix
Upgrade to a fixed version: NI Configuration Manager 22.5.0. Check the vendor advisory for mitigations.
References
- https://ni.com
- https://www.ni.com/en-us/support/documentation/supplemental/22/privilege-escalation-in-ni-configuration-manager-.html
- https://ni.com
- https://www.ni.com/en-us/support/documentation/supplemental/22/privilege-escalation-in-ni-configuration-manager-.html
Get alerted when CVE-2022-35415 or the next vulnerability affects your stack