What’s Vulnerable › Vulnerabilities
CVE-2022-3561: Cross-site Scripting (XSS) - Generic in librenms/librenms
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Generic in GitHub repository librenms/librenms prior to 22.10.0.
Affected products
- librenms: before 22.10.0 — fixed in 22.10.0
How to fix
Upgrade to a fixed version: librenms 22.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/d86cbcd96d684e4de8dfa50b4490e4e02782d242
- https://huntr.dev/bounties/7389e6eb-4bce-4b97-999d-d3b70d8cee34
- https://github.com/librenms/librenms/commit/d86cbcd96d684e4de8dfa50b4490e4e02782d242
- https://huntr.dev/bounties/7389e6eb-4bce-4b97-999d-d3b70d8cee34
- https://huntr.com/bounties/7389e6eb-4bce-4b97-999d-d3b70d8cee34
Get alerted when CVE-2022-3561 or the next vulnerability affects your stack