What’s Vulnerable › Vulnerabilities
CVE-2022-3562: Cross-site Scripting (XSS) - Stored in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 94.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.10.0.
Affected products
- librenms: before 22.10.0 — fixed in 22.10.0
How to fix
Upgrade to a fixed version: librenms 22.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/43cb72549d90e338f902b359a83c23d3cb5a2645
- https://huntr.dev/bounties/bb9f76db-1314-44ae-9ccc-2b69679aa657
- https://github.com/librenms/librenms/commit/43cb72549d90e338f902b359a83c23d3cb5a2645
- https://huntr.dev/bounties/bb9f76db-1314-44ae-9ccc-2b69679aa657
Get alerted when CVE-2022-3562 or the next vulnerability affects your stack