What’s Vulnerable › Vulnerabilities
CVE-2022-35632: XSS in User Interface
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Velociraptor GUI contains an editor suggestion feature that can display the description field of a VQL function, plugin or artifact. This field was not properly sanitized and can lead to cross-site scripting (XSS). This issue was resolved in Velociraptor 0.6.5-2.
Affected products
- Rapid7 Velociraptor: before 0.6.5-2 — fixed in 0.6.5-2
How to fix
Upgrade to a fixed version: Rapid7 Velociraptor 0.6.5-2. Check the vendor advisory for mitigations.
References
- https://www.rapid7.com/blog/post/2022/07/26/cve-2022-35629-35632-velociraptor-multiple-vulnerabilities-fixed/
- https://www.rapid7.com/blog/post/2022/07/26/cve-2022-35629-35632-velociraptor-multiple-vulnerabilities-fixed/
Get alerted when CVE-2022-35632 or the next vulnerability affects your stack