What’s Vulnerable › Vulnerabilities

CVE-2022-35649

Description

The vulnerability was found in Moodle, occurs due to improper input validation when parsing PostScript code. An omitted execution parameter results in a remote code execution risk for sites running GhostScript versions older than 9.50. Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.11.8, 3.9.15, 4.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-35649 or the next vulnerability affects your stack