What’s Vulnerable › Vulnerabilities
CVE-2022-35650
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 53.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-22
Description
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
Affected products
- Fedoraproject Fedora: 35, 36
- Moodle: from 3.9.0 before 3.9.15; from 3.11.0 before 3.11.8; from 4.0.0 before 4.0.2 — fixed in 3.11.8, 3.9.15, 4.0.2
How to fix
Upgrade to a fixed version: Moodle 3.11.8, 3.9.15, 4.0.2. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72029
- https://bugzilla.redhat.com/show_bug.cgi?id=2106274
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V/
- https://moodle.org/mod/forum/discuss.php?d=436457
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72029
- https://bugzilla.redhat.com/show_bug.cgi?id=2106274
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V/
- https://moodle.org/mod/forum/discuss.php?d=436457
Get alerted when CVE-2022-35650 or the next vulnerability affects your stack