What’s Vulnerable › Vulnerabilities
CVE-2022-35651
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored XSS and blind SSRF vulnerability was found in Moodle, occurs due to insufficient sanitization of user-supplied data in the SCORM track details. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks.
Affected products
- Fedoraproject Fedora: 35, 36
- Moodle: from 3.9.0 before 3.9.15; from 3.11.0 before 3.11.8; 4.0.0, 4.0.0-beta, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 4.0.0-rc4 (+1) — fixed in 3.11.8, 3.9.15
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: Moodle 3.11.8, 3.9.15. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-71921
- https://bugzilla.redhat.com/show_bug.cgi?id=2106275
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V/
- https://moodle.org/mod/forum/discuss.php?d=436458
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-71921
- https://bugzilla.redhat.com/show_bug.cgi?id=2106275
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V/
- https://moodle.org/mod/forum/discuss.php?d=436458
Get alerted when CVE-2022-35651 or the next vulnerability affects your stack