What’s Vulnerable › Vulnerabilities
CVE-2022-35653
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-79
Description
A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.
Affected products
- Fedoraproject Fedora: 35, 36
- Moodle: from 3.9.0 before 3.9.15; from 3.11.0 before 3.11.8; 4.0.0, 4.0.0-beta, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 4.0.0-rc4 (+1) — fixed in 3.11.8, 3.9.15
- Red Hat Enterprise Linux: 8.0
How to fix
Upgrade to a fixed version: Moodle 3.11.8, 3.9.15. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72299
- https://bugzilla.redhat.com/show_bug.cgi?id=2106277
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V/
- https://moodle.org/mod/forum/discuss.php?d=436460
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72299
- https://bugzilla.redhat.com/show_bug.cgi?id=2106277
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V/
- https://moodle.org/mod/forum/discuss.php?d=436460
Get alerted when CVE-2022-35653 or the next vulnerability affects your stack