What’s Vulnerable › Vulnerabilities
CVE-2022-35692: Adobe Commerce Improper Access Control Security feature bypass
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-19 · updated 2026-06-17
- Weakness: CWE-863
Description
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to leak minor information of another user's account detials. Exploitation of this issue does not require user interaction.
Affected products
- Adobe Commerce: from 2.4.0 before 2.4.4 — fixed in 2.4.4
- Adobe Magento Commerce: 2.3.7, 2.3.7-p1, 2.3.7-p2, 2.3.7-p3, 2.4.3, 2.4.3-p1 (+2)
How to fix
Upgrade to a fixed version: Adobe Commerce 2.4.4. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb22-38.html
- https://helpx.adobe.com/security/products/magento/apsb22-38.html
Get alerted when CVE-2022-35692 or the next vulnerability affects your stack