What’s Vulnerable › Vulnerabilities
CVE-2022-35698: Adobe Commerce Stored XSS Arbitrary code execution
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Adobe Commerce versions 2.4.4-p1 (and earlier) and 2.4.5 (and earlier) are affected by a Stored Cross-site Scripting vulnerability. Exploitation of this issue does not require user interaction and could result in a post-authentication arbitrary code execution.
Affected products
- Adobe Commerce: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.5 — fixed in 2.4.4
- Adobe Magento Open Source: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.5 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: Adobe Commerce 2.4.4; Adobe Magento Open Source 2.4.4. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb22-48.html
- https://helpx.adobe.com/security/products/magento/apsb22-48.html
Get alerted when CVE-2022-35698 or the next vulnerability affects your stack