What’s Vulnerable › Vulnerabilities
CVE-2022-35716
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-863
Description
IBM UrbanCode Deploy (UCD) 6.2.0.0 through 6.2.7.16, 7.0.0.0 through 7.0.5.11, 7.1.0.0 through 7.1.2.7, and 7.2.0.0 through 7.2.3.0 could allow an authenticated user to obtain sensitive information in some instances due to improper security checking. IBM X-Force ID: 231360.
Affected products
- IBM UrbanCode Deploy: from 6.2.0.0 before 6.2.7.17; from 7.0.0.0 before 7.0.5.12; from 7.1.0.0 before 7.1.2.8; from 7.2.0.0 before 7.2.3.1 — fixed in 6.2.7.17, 7.0.5.12, 7.1.2.8, 7.2.3.1
How to fix
Upgrade to a fixed version: IBM UrbanCode Deploy 6.2.7.17, 7.0.5.12, 7.1.2.8, 7.2.3.1. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/231360
- https://www.ibm.com/support/pages/node/6608584
- https://exchange.xforce.ibmcloud.com/vulnerabilities/231360
- https://www.ibm.com/support/pages/node/6608584
Get alerted when CVE-2022-35716 or the next vulnerability affects your stack