What’s Vulnerable › Vulnerabilities
CVE-2022-35724: Denial of service while reading data in Avro Rust SDK
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-09 · updated 2026-06-17
- Weakness: CWE-20
Description
It is possible to provide data to be read that leads the reader to loop in cycles endlessly, consuming CPU. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.
Affected products
- Apache Software Foundation Apache Avro: before 0.14.0 — fixed in 0.14.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Avro 0.14.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/771z1nwrpkn1ovmyfb2fm65mchdxgy7p
- https://lists.apache.org/thread/771z1nwrpkn1ovmyfb2fm65mchdxgy7p
Get alerted when CVE-2022-35724 or the next vulnerability affects your stack