What’s Vulnerable › Vulnerabilities

CVE-2022-3573

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 15.4 before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. Due to the improper filtering of query parameters in the wiki changes page, an attacker can execute arbitrary JavaScript on the self-hosted instances running without strict CSP.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.5.7, 15.6.4, 15.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3573 or the next vulnerability affects your stack