What’s Vulnerable › Vulnerabilities
CVE-2022-3578: ProfileGrid < 5.1.1 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The ProfileGrid WordPress plugin before 5.1.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting
Affected products
- metagauss ProfileGrid – User Profiles, Groups and Communities: before 5.1.1 — fixed in 5.1.1
How to fix
Upgrade to a fixed version: metagauss ProfileGrid – User Profiles, Groups and Communities 5.1.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/17596b0e-ff45-4d0c-8e57-a31101e30345
- https://wpscan.com/vulnerability/17596b0e-ff45-4d0c-8e57-a31101e30345
Get alerted when CVE-2022-3578 or the next vulnerability affects your stack