What’s Vulnerable › Vulnerabilities
CVE-2022-35902
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-15 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in Bentley MicroStation before 10.17.0.x and Bentley View before 10.17.0.x. Using an affected version of MicroStation or MicroStation-based application to open an OBJ file containing crafted data can force an out-of-bounds read. Exploitation of these vulnerabilities within the parsing of OBJ files could enable an attacker to read information in the context of the current process.
Affected products
- Bentley MicroStation: before 10.17.0 — fixed in 10.17.0
- Bentley View: before 10.17.0 — fixed in 10.17.0
How to fix
Upgrade to a fixed version: Bentley MicroStation 10.17.0; Bentley View 10.17.0. Check the vendor advisory for mitigations.
References
- https://www.bentley.com/en/common-vulnerability-exposure/be-2022-0016
- https://www.bentley.com/en/common-vulnerability-exposure/be-2022-0016
Get alerted when CVE-2022-35902 or the next vulnerability affects your stack