What’s Vulnerable › Vulnerabilities
CVE-2022-3591: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-02 · updated 2026-09-24
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0789.
Affected products
How to fix
Upgrade to a fixed version: Neovim 0.9.0; vim/vim 9.0.0789. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/8f3c3c6cd044e3b5bf08dbfa3b3f04bb3f711bad
- https://huntr.dev/bounties/a5a998c2-4b07-47a7-91be-dbc1886b3921
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/8f3c3c6cd044e3b5bf08dbfa3b3f04bb3f711bad
- https://huntr.dev/bounties/a5a998c2-4b07-47a7-91be-dbc1886b3921
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-3591 or the next vulnerability affects your stack