What’s Vulnerable › Vulnerabilities
CVE-2022-35912
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-19 · updated 2026-06-17
Description
In grails-databinding in Grails before 3.3.15, 4.x before 4.1.1, 5.x before 5.1.9, and 5.2.x before 5.2.1 (at least when certain Java 8 configurations are used), data binding allows a remote attacker to execute code by gaining access to the class loader.
Affected products
- grails-core: from 3.3.10 before 3.3.15; from 4.0.0 before 4.1.1; from 5.0.0 before 5.1.9; 5.2.0 — fixed in 3.3.15, 4.1.1, 5.1.9
How to fix
Upgrade to a fixed version: grails-core 3.3.15, 4.1.1, 5.1.9. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/07/20/4
- https://github.com/grails/grails-core/issues/12626
- https://github.com/grails/grails-core/security/advisories/GHSA-6rh6-x8ww-9h97
- https://grails.org/blog/2022-07-18-rce-vulnerability.html
- http://www.openwall.com/lists/oss-security/2022/07/20/4
- https://github.com/grails/grails-core/issues/12626
- https://github.com/grails/grails-core/security/advisories/GHSA-6rh6-x8ww-9h97
- https://grails.org/blog/2022-07-18-rce-vulnerability.html
Get alerted when CVE-2022-35912 or the next vulnerability affects your stack