What’s Vulnerable › Vulnerabilities
CVE-2022-35916: Cross chain utilities for Arbitrum L2 see EOA calls as cross chain calls
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-669
Description
OpenZeppelin Contracts is a library for secure smart contract development. Contracts using the cross chain utilities for Arbitrum L2, `CrossChainEnabledArbitrumL2` or `LibArbitrumL2`, will classify direct interactions of externally owned accounts (EOAs) as cross chain calls, even though they are not started on L1. This issue has been patched in v4.7.2. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- openzeppelin-contracts: from 4.6.0 before 4.7.2 — fixed in 4.7.2
- OpenZeppelin Contracts Upgradeable: from 4.6.0 before 4.7.2 — fixed in 4.7.2
How to fix
Upgrade to a fixed version: openzeppelin-contracts 4.7.2; OpenZeppelin Contracts Upgradeable 4.7.2. Check the vendor advisory for mitigations.
References
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3578
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-9j3m-g383-29qr
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3578
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-9j3m-g383-29qr
Get alerted when CVE-2022-35916 or the next vulnerability affects your stack