What’s Vulnerable › Vulnerabilities
CVE-2022-35921: User preference to prevent private discussions not respected in fof/byobu
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-01 · updated 2026-06-17
- Weakness: CWE-269
Description
fof/byobu is a private discussions extension for Flarum forum. Affected versions were found to not respect private discussion disablement by users. Users of Byobu should update the extension to version 1.1.7, where this has been patched. Users of Byobu with Flarum 1.0 or 1.1 should upgrade to Flarum 1.2 or later, or evaluate the impact this issue has on your forum's users and choose to disable the extension if needed. There are no workarounds for this issue.
Affected products
- FriendsOfFlarum byobu: from 0.32.0 before 1.1.7; 0.30.0-beta2 — fixed in 1.1.7
How to fix
Upgrade to a fixed version: FriendsOfFlarum byobu 1.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/FriendsOfFlarum/byobu/commit/23dcf93a30f948d30c678a96681f7fdefeba5171
- https://github.com/FriendsOfFlarum/byobu/security/advisories/GHSA-6gjm-6wj6-4px5
- https://github.com/FriendsOfFlarum/byobu/commit/23dcf93a30f948d30c678a96681f7fdefeba5171
- https://github.com/FriendsOfFlarum/byobu/security/advisories/GHSA-6gjm-6wj6-4px5
Get alerted when CVE-2022-35921 or the next vulnerability affects your stack