What’s Vulnerable › Vulnerabilities
CVE-2022-35925: Missing rate limit in Authentication in bookwyrm
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-02 · updated 2026-06-17
- Weakness: CWE-287
Description
BookWyrm is a social network for tracking reading. Versions prior to 0.4.5 were found to lack rate limiting on authentication views which allows brute-force attacks. This issue has been patched in version 0.4.5. Admins with existing instances will need to update their `nginx.conf` file that was created when the instance was set up. Users are advised advised to upgrade. Users unable to upgrade may update their nginx.conf files with the changes manually.
Affected products
- bookwyrm-social bookwyrm: before 0.4.5 — fixed in 0.4.5
How to fix
Upgrade to a fixed version: bookwyrm-social bookwyrm 0.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-jvp3-mqv8-5rjw
- https://huntr.dev/bounties/ebee593d-3fd0-4985-bf5e-7e7927e08bf6/
- https://www.github.com/bookwyrm-social/bookwyrm/commit/7bbe42fb30a79a26115524d18b697d895563c92f
- https://github.com/bookwyrm-social/bookwyrm/security/advisories/GHSA-jvp3-mqv8-5rjw
- https://huntr.dev/bounties/ebee593d-3fd0-4985-bf5e-7e7927e08bf6/
- https://www.github.com/bookwyrm-social/bookwyrm/commit/7bbe42fb30a79a26115524d18b697d895563c92f
Get alerted when CVE-2022-35925 or the next vulnerability affects your stack