What’s Vulnerable › Vulnerabilities
CVE-2022-35927: Unverified DIO prefix info lengths in RPL-Classic in Contiki-NG
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-04 · updated 2026-06-17
- Weakness: CWE-120
Description
Contiki-NG is an open-source, cross-platform operating system for IoT devices. In the RPL-Classic routing protocol implementation in the Contiki-NG operating system, an incoming DODAG Information Option (DIO) control message can contain a prefix information option with a length parameter. The value of the length parameter is not validated, however, and it is possible to cause a buffer overflow when copying the prefix in the set_ip_from_prefix function. This vulnerability affects anyone running a Contiki-NG version prior to 4.7 that can receive RPL DIO messages from external parties. To obtain a patched version, users should upgrade to Contiki-NG 4.7 or later. There are no workarounds for this issue.
Affected products
- contiki-ng: before 4.7 — fixed in 4.7
How to fix
Upgrade to a fixed version: contiki-ng 4.7. Check the vendor advisory for mitigations.
References
- https://github.com/contiki-ng/contiki-ng/pull/1589
- https://github.com/contiki-ng/contiki-ng/pull/1589/commits/4fffab0e632c4d01910fa957d1fd9ef321eb87d2
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-9rm9-3phh-p4wm
- https://github.com/contiki-ng/contiki-ng/pull/1589
- https://github.com/contiki-ng/contiki-ng/pull/1589/commits/4fffab0e632c4d01910fa957d1fd9ef321eb87d2
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-9rm9-3phh-p4wm
Get alerted when CVE-2022-35927 or the next vulnerability affects your stack