What’s Vulnerable › Vulnerabilities
CVE-2022-35930: Ability to bypass attestation verification in sigstore PolicyController
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-04 · updated 2026-06-17
- Weakness: CWE-347
Description
PolicyController is a utility used to enforce supply chain policy in Kubernetes clusters. In versions prior to 0.2.1 PolicyController will report a false positive, resulting in an admission when it should not be admitted when there is at least one attestation with a valid signature and there are NO attestations of the type being verified (--type defaults to "custom"). An example image that can be used to test this is `ghcr.io/distroless/static@sha256:dd7614b5a12bc4d617b223c588b4e0c833402b8f4991fb5702ea83afad1986e2`. Users should upgrade to version 0.2.1 to resolve this issue. There are no workarounds for users unable to upgrade.
Affected products
- sigstore policy-controller: before 0.2.1 — fixed in 0.2.1
How to fix
Upgrade to a fixed version: sigstore policy-controller 0.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/sigstore/policy-controller/commit/e852af36fb7d42678b21d7e97503c25bd1fd05c8
- https://github.com/sigstore/policy-controller/releases/tag/v0.2.1
- https://github.com/sigstore/policy-controller/security/advisories/GHSA-739f-hw6h-7wq8
- https://github.com/sigstore/policy-controller/commit/e852af36fb7d42678b21d7e97503c25bd1fd05c8
- https://github.com/sigstore/policy-controller/releases/tag/v0.2.1
- https://github.com/sigstore/policy-controller/security/advisories/GHSA-739f-hw6h-7wq8
Get alerted when CVE-2022-35930 or the next vulnerability affects your stack