What’s Vulnerable › Vulnerabilities
CVE-2022-35931: Nextcloud Password Policy's generated passwords are not fully validated by HIBPValidator
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-261
Description
Nextcloud Password Policy is an app that enables a Nextcloud server admin to define certain rules for passwords. Prior to versions 22.2.10, 23.0.7, and 24.0.3 the random password generator may, in very rare cases, generate common passwords that the validator itself would block. Upgrade Nextcloud Server to 22.2.10, 23.0.7 or 24.0.3 to receive a patch for the issue in Password Policy. There are no known workarounds available.
Affected products
- nextcloud Password Policy: before 22.2.10; from 23.0.0 before 23.0.7; from 24.0.0 before 24.0.3 — fixed in 22.2.10, 23.0.7, 24.0.3
How to fix
Upgrade to a fixed version: nextcloud Password Policy 22.2.10, 23.0.7, 24.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/password_policy/pull/363
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-c7mw-9q4r-8qwr
- https://github.com/nextcloud/password_policy/pull/363
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-c7mw-9q4r-8qwr
Get alerted when CVE-2022-35931 or the next vulnerability affects your stack