What’s Vulnerable › Vulnerabilities
CVE-2022-35933: PrestaShop module Product Comments vulnerable to cross-site scripting (XSS)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-02 · updated 2026-06-17
- Weakness: CWE-79
Description
This package is a PrestaShop module that allows users to post reviews and rate products. There is a vulnerability where the attacker could steal an administrator's cookie. The issue is fixed in version 5.0.2.
Affected products
- PrestaShop productcomments: before 5.0.2 — fixed in 5.0.2
How to fix
Upgrade to a fixed version: PrestaShop productcomments 5.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/productcomments/commit/314456d739155aa71f0b235827e8e0f24b97c26b
- https://github.com/PrestaShop/productcomments/security/advisories/GHSA-prrh-qvhf-x788
- https://github.com/PrestaShop/productcomments/commit/314456d739155aa71f0b235827e8e0f24b97c26b
- https://github.com/PrestaShop/productcomments/security/advisories/GHSA-prrh-qvhf-x788
Get alerted when CVE-2022-35933 or the next vulnerability affects your stack