What’s Vulnerable › Vulnerabilities
CVE-2022-35935: `CHECK` failure in `SobolSample` via missing validation in TensorFlow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-16 · updated 2026-06-17
- Weakness: CWE-617
Description
TensorFlow is an open source platform for machine learning. The implementation of SobolSampleOp is vulnerable to a denial of service via CHECK-failure (assertion failure) caused by assuming `input(0)`, `input(1)`, and `input(2)` to be scalar. This issue has been patched in GitHub commit c65c67f88ad770662e8f191269a907bf2b94b1bf. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.
Affected products
- tensorflow: from 2.7.0 before 2.7.2; from 2.8.0 before 2.8.1; from 2.9.0 before 2.9.1; 2.10-rc0, 2.10-rc1, 2.10-rc2, 2.10-rc3 — fixed in 2.7.2, 2.8.1, 2.9.1
How to fix
Upgrade to a fixed version: tensorflow 2.7.2, 2.8.1, 2.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/c65c67f88ad770662e8f191269a907bf2b94b1bf
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-97p7-w86h-vcf9
- https://github.com/tensorflow/tensorflow/commit/c65c67f88ad770662e8f191269a907bf2b94b1bf
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-97p7-w86h-vcf9
Get alerted when CVE-2022-35935 or the next vulnerability affects your stack