What’s Vulnerable › Vulnerabilities
CVE-2022-35943: SameSite may allow cross-site request forgery (CSRF) protection to be bypassed
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-12 · updated 2026-06-17
- Weakness: CWE-352
Description
Shield is an authentication and authorization framework for CodeIgniter 4. This vulnerability may allow [SameSite Attackers](https://canitakeyoursubdomain.name/) to bypass the [CodeIgniter4 CSRF protection](https://codeigniter4.github.io/userguide/libraries/security.html) mechanism with CodeIgniter Shield. For this attack to succeed, the attacker must have direct (or indirect, e.g., XSS) control over a subdomain site (e.g., `https://a.example.com/`) of the target site (e.g., `http://example.com/`). Upgrade to **CodeIgniter v4.2.3 or later** and **Shield v1.0.0-beta.2 or later**. As a workaround: set `Config\Security::$csrfProtection` to `'session,'`remove old session data right after login (immediately after ID and password match) and regenerate CSRF token right after login (immediately after ID and password match)
Affected products
- CodeIgniter4: before 4.2.3 — fixed in 4.2.3
- codeigniter4 shield: 1.0.0-beta
How to fix
Upgrade to a fixed version: CodeIgniter4 4.2.3. Check the vendor advisory for mitigations.
References
- https://codeigniter4.github.io/userguide/libraries/security.htm
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Set-Cookie/SameSite
- https://github.com/codeigniter4/shield/security/advisories/GHSA-5hm8-vh6r-2cjq
- https://jub0bs.com/posts/2021-01-29-great-samesite-confusion
- https://codeigniter4.github.io/userguide/libraries/security.htm
- https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Set-Cookie/SameSite
- https://github.com/codeigniter4/shield/security/advisories/GHSA-5hm8-vh6r-2cjq
- https://jub0bs.com/posts/2021-01-29-great-samesite-confusion
Get alerted when CVE-2022-35943 or the next vulnerability affects your stack