What’s Vulnerable › Vulnerabilities
CVE-2022-35945: Cross site scripting (XSS) via registration API in GLPI
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-14 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI stands for Gestionnaire Libre de Parc Informatique and is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. Information associated to registration key are not properly escaped in registration key configuration page. They can be used to steal a GLPI administrator cookie. Users are advised to upgrade to 10.0.3. There are no known workarounds for this issue. ### Workarounds Do not use a registration key created by an untrusted person.
Affected products
- glpi-project glpi: before 10.0.3 — fixed in 10.0.3
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/2b8f9aa54ae4a4ec07bde0c8db739a292b8ec09a
- https://github.com/glpi-project/glpi/security/advisories/GHSA-jrgw-cx24-56x5
- https://github.com/glpi-project/glpi/commit/2b8f9aa54ae4a4ec07bde0c8db739a292b8ec09a
- https://github.com/glpi-project/glpi/security/advisories/GHSA-jrgw-cx24-56x5
Get alerted when CVE-2022-35945 or the next vulnerability affects your stack