What’s Vulnerable › Vulnerabilities
CVE-2022-35947: SQL injection in GLPI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-14 · updated 2026-06-17
- Weakness: CWE-89
Description
GLPI stands for Gestionnaire Libre de Parc Informatique and is a Free Asset and IT Management Software package, that provides ITIL Service Desk features, licenses tracking and software auditing. Affected versions have been found to be vulnerable to a SQL injection attack which an attacker could leverage to simulate an arbitrary user login. Users are advised to upgrade to version 10.0.3. Users unable to upgrade should disable the `Enable login with external token` API configuration.
Affected products
- glpi-project glpi: before 10.0.3 — fixed in 10.0.3
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.3. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/564309d2c1180d5ba1615f4bbaf6623df81b4962
- https://github.com/glpi-project/glpi/security/advisories/GHSA-7p3q-cffg-c8xh
- https://github.com/glpi-project/glpi/commit/564309d2c1180d5ba1615f4bbaf6623df81b4962
- https://github.com/glpi-project/glpi/security/advisories/GHSA-7p3q-cffg-c8xh
Get alerted when CVE-2022-35947 or the next vulnerability affects your stack