What’s Vulnerable › Vulnerabilities
CVE-2022-35949: `undici.request` vulnerable to SSRF using absolute URL on `pathname`
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-12 · updated 2026-06-17
- Weakness: CWE-918
Description
undici is an HTTP/1.1 client, written from scratch for Node.js.`undici` is vulnerable to SSRF (Server-side Request Forgery) when an application takes in **user input** into the `path/pathname` option of `undici.request`. If a user specifies a URL such as `http://127.0.0.1` or `//127.0.0.1` ```js const undici = require("undici") undici.request({origin: "http://example.com", pathname: "//127.0.0.1"}) ``` Instead of processing the request as `http://example.org//127.0.0.1` (or `http://example.org/http://127.0.0.1` when `http://127.0.0.1 is used`), it actually processes the request as `http://127.0.0.1/` and sends it to `http://127.0.0.1`. If a developer passes in user input into `path` parameter of `undici.request`, it can result in an _SSRF_ as they will assume that the hostname cannot change, when in actual fact it can change because the specified path parameter is combined with the base URL. This issue was fixed in `undici@5.8.1`. The best workaround is to validate user input before passing it to the `undici.request` call.
Affected products
- undici: through 5.8.1
- Npm Undici: before 5.8.2 — fixed in 5.8.2
How to fix
Upgrade to a fixed version: Npm Undici 5.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/nodejs/undici/commit/124f7ebf705366b2e1844dff721928d270f87895
- https://github.com/nodejs/undici/releases/tag/v5.8.2
- https://github.com/nodejs/undici/security/advisories/GHSA-8qr4-xgw6-wmr3
- https://github.com/nodejs/undici/commit/124f7ebf705366b2e1844dff721928d270f87895
- https://github.com/nodejs/undici/releases/tag/v5.8.2
- https://github.com/nodejs/undici/security/advisories/GHSA-8qr4-xgw6-wmr3
Get alerted when CVE-2022-35949 or the next vulnerability affects your stack