What’s Vulnerable › Vulnerabilities
CVE-2022-35954: Delimiter injection vulnerability in @actions/core exportVariable
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-15 · updated 2026-06-17
- Weakness: CWE-77
Description
The GitHub Actions ToolKit provides a set of packages to make creating actions easier. The `core.exportVariable` function uses a well known delimiter that attackers can use to break out of that specific variable and assign values to other arbitrary variables. Workflows that write untrusted values to the `GITHUB_ENV` file may cause the path or other environment variables to be modified without the intention of the workflow or action author. Users should upgrade to `@actions/core v1.9.1`. If you are unable to upgrade the `@actions/core` package, you can modify your action to ensure that any user input does not contain the delimiter `_GitHubActionsFileCommandDelimeter_` before calling `core.exportVariable`.
Affected products
- actions toolkit: before 1.9.1 — fixed in 1.9.1
How to fix
Upgrade to a fixed version: actions toolkit 1.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/actions/toolkit/commit/4beda9cbc00ba6eefe387a937c21087ccb8ee9df
- https://github.com/actions/toolkit/security/advisories/GHSA-7r3h-m5j6-3q42
- https://github.com/actions/toolkit/commit/4beda9cbc00ba6eefe387a937c21087ccb8ee9df
- https://github.com/actions/toolkit/security/advisories/GHSA-7r3h-m5j6-3q42
Get alerted when CVE-2022-35954 or the next vulnerability affects your stack