What’s Vulnerable › Vulnerabilities
CVE-2022-35977: Integer overflow in certain command arguments can drive Redis to OOM panic
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-20 · updated 2026-06-17
- Weakness: CWE-190
Description
Redis is an in-memory database that persists on disk. Authenticated users issuing specially crafted `SETRANGE` and `SORT(_RO)` commands can trigger an integer overflow, resulting with Redis attempting to allocate impossible amounts of memory and abort with an out-of-memory (OOM) panic. The problem is fixed in Redis versions 7.0.8, 6.2.9 and 6.0.17. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- Redis: from 6.0.0 before 6.0.17; from 6.2.0 before 6.2.9; from 7.0.0 before 7.0.8 — fixed in 6.0.17, 6.2.9, 7.0.8
How to fix
Upgrade to a fixed version: Redis 6.0.17, 6.2.9, 7.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/redis/redis/commit/1ec82e6e97e1db06a72ca505f9fbf6b981f31ef7
- https://github.com/redis/redis/releases/tag/6.0.17
- https://github.com/redis/redis/releases/tag/6.2.9
- https://github.com/redis/redis/releases/tag/7.0.8
- https://github.com/redis/redis/security/advisories/GHSA-mrcw-fhw9-fj8j
- https://github.com/redis/redis/commit/1ec82e6e97e1db06a72ca505f9fbf6b981f31ef7
- https://github.com/redis/redis/releases/tag/6.0.17
- https://github.com/redis/redis/releases/tag/6.2.9
- https://github.com/redis/redis/releases/tag/7.0.8
- https://github.com/redis/redis/security/advisories/GHSA-mrcw-fhw9-fj8j
- https://lists.debian.org/debian-lts-announce/2024/11/msg00031.html
Get alerted when CVE-2022-35977 or the next vulnerability affects your stack