What’s Vulnerable › Vulnerabilities
CVE-2022-36006: Authenticated remote code execution due to insecure deserialization (GHSL-2022-063)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-15 · updated 2026-06-17
- Weakness: CWE-94
Description
Arvados is an open source platform for managing, processing, and sharing genomic and other large scientific and biomedical data. A remote code execution (RCE) vulnerability in the Arvados Workbench allows authenticated attackers to execute arbitrary code via specially crafted JSON payloads. This exists in all versions up to 2.4.1 and is fixed in 2.4.2. This vulnerability is specific to the Ruby on Rails Workbench application (“Workbench 1”). We do not believe any other Arvados components, including the TypesScript browser-based Workbench application (“Workbench 2”) or API Server, are vulnerable to this attack. For versions of Arvados earlier than 2.4.2: remove the Ruby-based "Workbench 1" app ("apt-get remove arvados-workbench") from your installation as a workaround.
Affected products
- arvados: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: arvados 2.4.2. Check the vendor advisory for mitigations.
References
- https://arvados.org/release-notes/2.4.2/
- https://dev.arvados.org/issues/19316
- https://github.com/arvados/arvados/security/advisories/GHSA-8867-q4xf-cqgm
- https://arvados.org/release-notes/2.4.2/
- https://dev.arvados.org/issues/19316
- https://github.com/arvados/arvados/security/advisories/GHSA-8867-q4xf-cqgm
Get alerted when CVE-2022-36006 or the next vulnerability affects your stack