What’s Vulnerable › Vulnerabilities
CVE-2022-3602: X.509 Email Address 4-byte Buffer Overflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 90.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-01 · updated 2026-06-17
- Weakness: CWE-787
Description
A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed the malicious certificate or for the application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address to overflow four attacker-controlled bytes on the stack. This buffer overflow could result in a crash (causing a denial of service) or potentially remote code execution. Many platforms implement stack overflow protections which would mitigate against the risk of remote code execution. The risk may be further mitigated based on stack layout for any given platform/compiler. Pre-announcements of CVE-2022-3602 described this issue as CRITICAL. Further analysis based on some of the mitigating factors described above have led this to be downgraded to HIGH. Users are still encouraged to upgrade to a new version as soon as possible. In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects. Fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6).
Affected products
- Fedoraproject Fedora: 36, 37, 26, 27
- Clustered Data ONTAP: all versions
- Node.js: from 18.0.0 before 18.11.0; 18.12.0, 19.0.0 — fixed in 18.11.0
- OpenSSL: from 3.0.0 before 3.0.7 — fixed in 3.0.7
How to fix
Upgrade to a fixed version: Node.js 18.11.0; OpenSSL 3.0.7. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/169687/OpenSSL-Security-Advisory-20221101.html
- http://www.openwall.com/lists/oss-security/2022/11/01/15
- http://www.openwall.com/lists/oss-security/2022/11/01/16
- http://www.openwall.com/lists/oss-security/2022/11/01/17
- http://www.openwall.com/lists/oss-security/2022/11/01/18
- http://www.openwall.com/lists/oss-security/2022/11/01/19
- http://www.openwall.com/lists/oss-security/2022/11/01/20
- http://www.openwall.com/lists/oss-security/2022/11/01/21
- http://www.openwall.com/lists/oss-security/2022/11/01/24
- http://www.openwall.com/lists/oss-security/2022/11/02/1
- http://www.openwall.com/lists/oss-security/2022/11/02/10
- http://www.openwall.com/lists/oss-security/2022/11/02/11
Get alerted when CVE-2022-3602 or the next vulnerability affects your stack