What’s Vulnerable › Vulnerabilities
CVE-2022-36023: Remote denial of service in Hyperledger Fabric Gateway
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-18 · updated 2026-06-17
- Weakness: CWE-20
Description
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
Affected products
- hyperledger fabric: before 2.4.6 — fixed in 2.4.6
How to fix
Upgrade to a fixed version: hyperledger fabric 2.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/hyperledger/fabric/pull/3572
- https://github.com/hyperledger/fabric/pull/3576
- https://github.com/hyperledger/fabric/pull/3577
- https://github.com/hyperledger/fabric/releases/tag/v2.4.6
- https://github.com/hyperledger/fabric/security/advisories/GHSA-qj6r-fhrc-jj5r
- https://github.com/hyperledger/fabric/pull/3572
- https://github.com/hyperledger/fabric/pull/3576
- https://github.com/hyperledger/fabric/pull/3577
- https://github.com/hyperledger/fabric/releases/tag/v2.4.6
- https://github.com/hyperledger/fabric/security/advisories/GHSA-qj6r-fhrc-jj5r
Get alerted when CVE-2022-36023 or the next vulnerability affects your stack