What’s Vulnerable › Vulnerabilities
CVE-2022-36026: `CHECK` fail in `QuantizeAndDequantizeV3` in TensorFlow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-16 · updated 2026-06-17
- Weakness: CWE-617
Description
TensorFlow is an open source platform for machine learning. If `QuantizeAndDequantizeV3` is given a nonscalar `num_bits` input tensor, it results in a `CHECK` fail that can be used to trigger a denial of service attack. We have patched the issue in GitHub commit f3f9cb38ecfe5a8a703f2c4a8fead434ef291713. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.
Affected products
- tensorflow: before 2.7.2; from 2.8.0 before 2.8.1; from 2.9.0 before 2.9.1; 2.10-rc0, 2.10-rc1, 2.10-rc2, 2.10-rc3 — fixed in 2.7.2, 2.8.1, 2.9.1
How to fix
Upgrade to a fixed version: tensorflow 2.7.2, 2.8.1, 2.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/f3f9cb38ecfe5a8a703f2c4a8fead434ef291713
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9cr2-8pwr-fhfq
- https://github.com/tensorflow/tensorflow/commit/f3f9cb38ecfe5a8a703f2c4a8fead434ef291713
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9cr2-8pwr-fhfq
Get alerted when CVE-2022-36026 or the next vulnerability affects your stack