What’s Vulnerable › Vulnerabilities
CVE-2022-36045: Account takeover via cryptographically weak PRNG in NodeBB Forum
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-31 · updated 2026-06-17
- Weakness: CWE-330
Description
NodeBB Forum Software is powered by Node.js and supports either Redis, MongoDB, or a PostgreSQL database. It utilizes web sockets for instant interactions and real-time notifications. `utils.generateUUID`, a helper function available in essentially all versions of NodeBB (as far back as v1.0.1 and potentially earlier) used a cryptographically insecure Pseudo-random number generator (`Math.random()`), which meant that a specially crafted script combined with multiple invocations of the password reset functionality could enable an attacker to correctly calculate the reset code for an account they do not have access to. This vulnerability impacts all installations of NodeBB. The vulnerability allows for an attacker to take over any account without the involvement of the victim, and as such, the remediation should be applied immediately (either via NodeBB upgrade or cherry-pick of the specific changeset. The vulnerability has been patched in version 2.x and 1.19.x. There is no known workaround, but the patch sets listed above will fully patch the vulnerability.
Affected products
- NodeBB: before 1.19.8; 2.0.0 — fixed in 1.19.8
How to fix
Upgrade to a fixed version: NodeBB 1.19.8. Check the vendor advisory for mitigations.
References
- https://github.com/NodeBB/NodeBB/commit/81e3c1ba488d03371a5ce8d0ebb5c5803026e0f9
- https://github.com/NodeBB/NodeBB/commit/e802fab87f94a13f397f04cfe6068f2f7ddf7888
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-p4cc-w597-6cpm
- https://github.com/NodeBB/NodeBB/commit/81e3c1ba488d03371a5ce8d0ebb5c5803026e0f9
- https://github.com/NodeBB/NodeBB/commit/e802fab87f94a13f397f04cfe6068f2f7ddf7888
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-p4cc-w597-6cpm
Get alerted when CVE-2022-36045 or the next vulnerability affects your stack