What’s Vulnerable › Vulnerabilities
CVE-2022-36054: Out-of-bounds write when decompressing 6LoWPAN payload in Contiki-NG
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-01 · updated 2026-06-17
- Weakness: CWE-787
Description
Contiki-NG is an open-source, cross-platform operating system for Next-Generation IoT devices. The 6LoWPAN implementation in the Contiki-NG operating system (file os/net/ipv6/sicslowpan.c) contains an input function that processes incoming packets and copies them into a packet buffer. Because of a missing length check in the input function, it is possible to write outside the packet buffer's boundary. The vulnerability can be exploited by anyone who has the possibility to send 6LoWPAN packets to a Contiki-NG system. In particular, the vulnerability is exposed when sending either of two types of 6LoWPAN packets: an unfragmented packet or the first fragment of a fragmented packet. If the packet is sufficiently large, a subsequent memory copy will cause an out-of-bounds write with data supplied by the attacker.
Affected products
- contiki-ng: before 4.8 — fixed in 4.8
How to fix
Upgrade to a fixed version: contiki-ng 4.8. Check the vendor advisory for mitigations.
References
- https://github.com/contiki-ng/contiki-ng/pull/1648
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-c36p-vhwg-244c
- https://github.com/contiki-ng/contiki-ng/pull/1648
- https://github.com/contiki-ng/contiki-ng/security/advisories/GHSA-c36p-vhwg-244c
Get alerted when CVE-2022-36054 or the next vulnerability affects your stack