What’s Vulnerable › Vulnerabilities
CVE-2022-36055: Denial of service in Helm
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-01 · updated 2026-06-17
- Weakness: CWE-400
Description
Helm is a tool for managing Charts. Charts are packages of pre-configured Kubernetes resources. Fuzz testing, provided by the CNCF, identified input to functions in the _strvals_ package that can cause an out of memory panic. The _strvals_ package contains a parser that turns strings in to Go structures. The _strvals_ package converts these strings into structures Go can work with. Some string inputs can cause array data structures to be created causing an out of memory panic. Applications that use the _strvals_ package in the Helm SDK to parse user supplied input can suffer a Denial of Service when that input causes a panic that cannot be recovered from. The Helm Client will panic with input to `--set`, `--set-string`, and other value setting flags that causes an out of memory panic. Helm is not a long running service so the panic will not affect future uses of the Helm client. This issue has been resolved in 3.9.4. SDK users can validate strings supplied by users won't create large arrays causing significant memory usage before passing them to the _strvals_ functions.
Affected products
- helm: from 3.0.0 before 3.9.4 — fixed in 3.9.4
How to fix
Upgrade to a fixed version: helm 3.9.4. Check the vendor advisory for mitigations.
References
- https://github.com/helm/helm/releases/tag/v3.9.4
- https://github.com/helm/helm/security/advisories/GHSA-7hfp-qfw3-5jxh
- https://github.com/helm/helm/releases/tag/v3.9.4
- https://github.com/helm/helm/security/advisories/GHSA-7hfp-qfw3-5jxh
Get alerted when CVE-2022-36055 or the next vulnerability affects your stack