What’s Vulnerable › Vulnerabilities
CVE-2022-36057: Discourse-Chat Cross-Site Scripting issue for channel names and descriptions
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse-Chat is an asynchronous messaging plugin for the Discourse open-source discussion platform. Users of Discourse Chat can be affected by admin users inserting HTML into chat titles and descriptions, causing a Cross-Site Scripting (XSS) attack. Version 0.9 contains a patch for this issue.
Affected products
- discourse-chat: before 0.9 — fixed in 0.9
How to fix
Upgrade to a fixed version: discourse-chat 0.9. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse-chat/pull/1205
- https://github.com/discourse/discourse-chat/security/advisories/GHSA-3vf2-wrjx-p6xj
- https://github.com/discourse/discourse-chat/pull/1205
- https://github.com/discourse/discourse-chat/security/advisories/GHSA-3vf2-wrjx-p6xj
Get alerted when CVE-2022-36057 or the next vulnerability affects your stack