What’s Vulnerable › Vulnerabilities
CVE-2022-36066: Discourse vulnerable to RCE via admins uploading maliciously zipped file
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-29 · updated 2026-06-17
- Weakness: CWE-434
Description
Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, admins can upload a maliciously crafted Zip or Gzip Tar archive to write files at arbitrary locations and trigger remote code execution. The problem is patched in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: before 2.8.9; 2.9.0-beta1, 2.9.0-beta2, 2.9.0-beta3, 2.9.0-beta4, 2.9.0-beta5, 2.9.0-beta6 (+3) — fixed in 2.8.9
How to fix
Upgrade to a fixed version: discourse 2.8.9. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/b27d5626d208a22c516a0adfda7554b67b493835
- https://github.com/discourse/discourse/pull/18421
- https://github.com/discourse/discourse/security/advisories/GHSA-grvh-qcpg-hfmv
- https://github.com/discourse/discourse/commit/b27d5626d208a22c516a0adfda7554b67b493835
- https://github.com/discourse/discourse/pull/18421
- https://github.com/discourse/discourse/security/advisories/GHSA-grvh-qcpg-hfmv
Get alerted when CVE-2022-36066 or the next vulnerability affects your stack