What’s Vulnerable › Vulnerabilities
CVE-2022-36067: vm2 vulnerable to Sandbox Escape before v3.9.11
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 47.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-913
Description
vm2 is a sandbox that can run untrusted code with whitelisted Node's built-in modules. In versions prior to version 3.9.11, a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version 3.9.11 of vm2. There are no known workarounds.
Affected products
- patriksimek vm2: before 3.9.11 — fixed in 3.9.11
How to fix
Upgrade to a fixed version: patriksimek vm2 3.9.11. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/blob/master/lib/setup-sandbox.js#L71
- https://github.com/patriksimek/vm2/commit/d9a7f3cc995d3d861e1380eafb886cb3c5e2b873#diff-b1a515a627d820118e76d0e323fe2f0589ed50a1eacb490f6c3278fe3698f164
- https://github.com/patriksimek/vm2/issues/467
- https://github.com/patriksimek/vm2/security/advisories/GHSA-mrgp-mrhc-5jrq
- https://security.netapp.com/advisory/ntap-20221017-0002/
- https://www.oxeye.io/blog/vm2-sandbreak-vulnerability-cve-2022-36067
- https://github.com/patriksimek/vm2/blob/master/lib/setup-sandbox.js#L71
- https://github.com/patriksimek/vm2/commit/d9a7f3cc995d3d861e1380eafb886cb3c5e2b873#diff-b1a515a627d820118e76d0e323fe2f0589ed50a1eacb490f6c3278fe3698f164
- https://github.com/patriksimek/vm2/issues/467
- https://github.com/patriksimek/vm2/security/advisories/GHSA-mrgp-mrhc-5jrq
- https://security.netapp.com/advisory/ntap-20221017-0002/
- https://www.oxeye.io/blog/vm2-sandbreak-vulnerability-cve-2022-36067
Get alerted when CVE-2022-36067 or the next vulnerability affects your stack