What’s Vulnerable › Vulnerabilities
CVE-2022-36068: Discourse moderators can edit themes via the API
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-29 · updated 2026-06-17
- Weakness: CWE-862
Description
Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, a moderator can create new and edit existing themes by using the API when they should not be able to do so. The problem is patched in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.
Affected products
- discourse: before 2.8.9; 2.9.0-beta1, 2.9.0-beta2, 2.9.0-beta3, 2.9.0-beta4, 2.9.0-beta5, 2.9.0-beta6 (+3) — fixed in 2.8.9
How to fix
Upgrade to a fixed version: discourse 2.8.9. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/ae1e536e83940d58f1c79b835c75c249121c46b6
- https://github.com/discourse/discourse/pull/18418
- https://github.com/discourse/discourse/security/advisories/GHSA-6crr-3662-263q
- https://github.com/discourse/discourse/commit/ae1e536e83940d58f1c79b835c75c249121c46b6
- https://github.com/discourse/discourse/pull/18418
- https://github.com/discourse/discourse/security/advisories/GHSA-6crr-3662-263q
Get alerted when CVE-2022-36068 or the next vulnerability affects your stack