What’s Vulnerable › Vulnerabilities
CVE-2022-36076: Account takeover via SSO plugins in NodeBB
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-02 · updated 2026-06-17
- Weakness: CWE-352
Description
NodeBB Forum Software is powered by Node.js and supports either Redis, MongoDB, or a PostgreSQL database. Due to an unnecessarily strict conditional in the code handling the first step of the SSO process, the pre-existing logic that added (and later checked) a nonce was inadvertently rendered opt-in instead of opt-out. This re-exposed a vulnerability in that a specially crafted Man-in-the-Middle (MITM) attack could theoretically take over another user account during the single sign-on process. The issue has been fully patched in version 1.17.2.
Affected products
- NodeBB: before 1.17.2 — fixed in 1.17.2
How to fix
Upgrade to a fixed version: NodeBB 1.17.2. Check the vendor advisory for mitigations.
References
- https://blogs.opera.com/security/2022/03/bug-bounty-adventures-a-nodebb-0-day/
- https://github.com/NodeBB/NodeBB/commit/a2400f6baff44cb2996487bcd0cc6e2acc74b3d4
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-xmgg-fx9p-prq6
- https://blogs.opera.com/security/2022/03/bug-bounty-adventures-a-nodebb-0-day/
- https://github.com/NodeBB/NodeBB/commit/a2400f6baff44cb2996487bcd0cc6e2acc74b3d4
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-xmgg-fx9p-prq6
Get alerted when CVE-2022-36076 or the next vulnerability affects your stack