What’s Vulnerable › Vulnerabilities
CVE-2022-36080: Wikmd Cross-site Scripting vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-07 · updated 2026-06-17
- Weakness: CWE-79
Description
Wikmd is a file based wiki that uses markdown. Prior to version 1.7.1, an attacker could capture user's session cookies or execute malicious Javascript when a victim edits a markdown file. Version 1.7.1 fixes this issue.
Affected products
- Linbreux wikmd: before 1.7.1 — fixed in 1.7.1
How to fix
Upgrade to a fixed version: Linbreux wikmd 1.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/Linbreux/wikmd/commit/259412c47d64d5b85980f95345179fbf05927798
- https://github.com/Linbreux/wikmd/security/advisories/GHSA-9m4m-6gqx-gfj3
- https://github.com/Linbreux/wikmd/commit/259412c47d64d5b85980f95345179fbf05927798
- https://github.com/Linbreux/wikmd/security/advisories/GHSA-9m4m-6gqx-gfj3
Get alerted when CVE-2022-36080 or the next vulnerability affects your stack