What’s Vulnerable › Vulnerabilities

CVE-2022-36084: cruddl vulnerable to AQL injection through flexSearch

Description

cruddl is software for creating a GraphQL API for a database, using the GraphQL SDL to model a schema. If cruddl starting with version 1.1.0 and prior to versions 2.7.0 and 3.0.2 is used to generate a schema that uses `@flexSearchFulltext`, users of that schema may be able to inject arbitrary AQL queries that will be forwarded to and executed by ArangoDB. Schemas that do not use `@flexSearchFulltext` are not affected. The attacker needs to have `READ` permission to at least one root entity type that has `@flexSearchFulltext` enabled. The issue has been fixed in version 3.0.2 and in version 2.7.0 of cruddl. As a workaround, users can temporarily remove `@flexSearchFulltext` from their schemas.

Affected products

How to fix

Upgrade to a fixed version: AEB-labs cruddl 2.7.0, 3.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-36084 or the next vulnerability affects your stack