What’s Vulnerable › Vulnerabilities
CVE-2022-36085: OPA Compiler: Bypass of WithUnsafeBuiltins using `with` keyword to mock functions
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-08 · updated 2026-06-17
- Weakness: CWE-20
Description
Open Policy Agent (OPA) is an open source, general-purpose policy engine. The Rego compiler provides a (deprecated) `WithUnsafeBuiltins` function, which allows users to provide a set of built-in functions that should be deemed unsafe — and as such rejected — by the compiler if encountered in the policy compilation stage. A bypass of this protection has been found, where the use of the `with` keyword to mock such a built-in function (a feature introduced in OPA v0.40.0), isn’t taken into account by `WithUnsafeBuiltins`. Multiple conditions need to be met in order to create an adverse effect. Version 0.43.1 contains a patch for this issue. As a workaround, avoid using the `WithUnsafeBuiltins` function and use the `capabilities` feature instead.
Affected products
- Openpolicyagent Open Policy Agent: from 0.40.0 before 0.43.1 — fixed in 0.43.1
How to fix
Upgrade to a fixed version: Openpolicyagent Open Policy Agent 0.43.1. Check the vendor advisory for mitigations.
References
- https://github.com/open-policy-agent/opa/commit/25a597bc3f4985162e7f65f9c36599f4f8f55823
- https://github.com/open-policy-agent/opa/commit/3e8c754ed007b22393cf65e48751ad9f6457fee8
- https://github.com/open-policy-agent/opa/pull/4540
- https://github.com/open-policy-agent/opa/pull/4616
- https://github.com/open-policy-agent/opa/releases/tag/v0.43.1
- https://github.com/open-policy-agent/opa/security/advisories/GHSA-f524-rf33-2jjr
- https://github.com/open-policy-agent/opa/commit/25a597bc3f4985162e7f65f9c36599f4f8f55823
- https://github.com/open-policy-agent/opa/commit/3e8c754ed007b22393cf65e48751ad9f6457fee8
- https://github.com/open-policy-agent/opa/pull/4540
- https://github.com/open-policy-agent/opa/pull/4616
- https://github.com/open-policy-agent/opa/releases/tag/v0.43.1
- https://github.com/open-policy-agent/opa/security/advisories/GHSA-f524-rf33-2jjr
Get alerted when CVE-2022-36085 or the next vulnerability affects your stack