What’s Vulnerable › Vulnerabilities

CVE-2022-36087: OAuthLib vulnerable DoS when attacker provides malicious IPV6 URI

Description

OAuthLib is an implementation of the OAuth request-signing logic for Python 3.6+. In OAuthLib versions 3.1.1 until 3.2.1, an attacker providing malicious redirect uri can cause denial of service. An attacker can also leverage usage of `uri_validate` functions depending where it is used. OAuthLib applications using OAuth2.0 provider support or use directly `uri_validate` are affected by this issue. Version 3.2.1 contains a patch. There are no known workarounds.

Affected products

How to fix

Upgrade to a fixed version: Oauthlib Project Oauthlib 3.2.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-36087 or the next vulnerability affects your stack