What’s Vulnerable › Vulnerabilities
CVE-2022-36088: GoCD Windows installations outside default location inadequately restrict installation file permissions
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-07 · updated 2026-06-17
- Weakness: CWE-269
Description
GoCD is a continuous delivery server. Windows installations via either the server or agent installers for GoCD prior to 22.2.0 do not adequately restrict permissions when installing outside of the default location. This could allow a malicious user with local access to the server GoCD Server or Agent are installed on to modify executables or components of the installation. This does not affect zip file-based installs, installations to other platforms, or installations inside `Program Files` or `Program Files (x86)`. This issue is fixed in GoCD 22.2.0 installers. As a workaround, if the server or agent is installed outside of `Program Files (x86)`, verify the the permission of the Server or Agent installation directory to ensure the `Everyone` user group does not have `Full Control`, `Modify` or `Write` permissions.
Affected products
- gocd: before 22.2.0 — fixed in 22.2.0
How to fix
Upgrade to a fixed version: gocd 22.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gocd/gocd/commit/96add9605096ab50c5cd4c229be1d503aff506a6
- https://github.com/gocd/gocd/releases/tag/22.2.0
- https://github.com/gocd/gocd/security/advisories/GHSA-gpv4-xqhc-5vcj
- https://www.gocd.org/releases/#22-2-0
- https://github.com/gocd/gocd/commit/96add9605096ab50c5cd4c229be1d503aff506a6
- https://github.com/gocd/gocd/releases/tag/22.2.0
- https://github.com/gocd/gocd/security/advisories/GHSA-gpv4-xqhc-5vcj
- https://www.gocd.org/releases/#22-2-0
Get alerted when CVE-2022-36088 or the next vulnerability affects your stack