What’s Vulnerable › Vulnerabilities
CVE-2022-36089: VelaUX APIServer vulnerable to Authentication Bypass by Capture-replay
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-07 · updated 2026-06-17
- Weakness: CWE-294
Description
KubeVela is an application delivery platform Users using KubeVela's VelaUX APIServer could be affected by an authentication bypass vulnerability. In KubeVela prior to versions 1.4.11 and 1.5.4, VelaUX APIServer uses the `PlatformID` as the signed key to generate the JWT tokens for users. Another API called `getSystemInfo` exposes the platformID. This vulnerability allows users to use the platformID to re-generate the JWT tokens to bypass the authentication. Versions 1.4.11 and 1.5.4 contain a patch for this issue.
Affected products
- kubevela: from 1.4.0 before 1.4.11; from 1.5.0 before 1.5.3 — fixed in 1.4.11, 1.5.3
How to fix
Upgrade to a fixed version: kubevela 1.4.11, 1.5.3. Check the vendor advisory for mitigations.
References
- https://github.com/kubevela/kubevela/pull/4634
- https://github.com/kubevela/kubevela/security/advisories/GHSA-cq42-w295-r29q
- https://github.com/kubevela/kubevela/pull/4634
- https://github.com/kubevela/kubevela/security/advisories/GHSA-cq42-w295-r29q
Get alerted when CVE-2022-36089 or the next vulnerability affects your stack